Универсальные функции с примерами использования

Программирование - Универсальные функции

Замер времени вхождение в интервал разбить строку парсинг строки

216
14 универсальных функций, с примерами использования - для обычного и управляемого интерфейса

Вместо предисловия

Я знаю про CloudConf, и сервисы хранения кода, но на Инфостарте сижу каждый день, поэтому мне здесь удобнее. Да и возможность поделиться какими-то своими идеями, получив отклик, тоже интересна.
Код я оформляю в соответствии с соглашениями о написании кода.

 
1. Замер времени выполнения
 
 2. Проверка значения на вхождение в некоторый интервал
 
 3. Разбиение строки на левую и правую часть
 
 4. Преобразование табличного документа в коллекцию
 
 4.1 Табличный документ в таблицу значений (перебор)
 
 4.2. Табличный документ в дерево значений
 
 5. Загрузка файлов: выбор на клиенте, обработка на сервере
 
 6. Попытка записи данных в файл с таймаутом на время записи
 
 7. Проверка интернет-соединения (ping)
 
 8. Быстрое описание типа
 
 9. Шаблон чтения Excell через ADO
 
 10. Объединение ячеек шапки табличного документа с повторяющимся текстом
 
 11. Формирование идентификатора по строке
 
 12. Формирование структуры для первой (единственной) записи результата запроса
 
 13. Проверка входящей строки на соответствие паттерну GUID
216

См. также

Комментарии
Избранное Подписка Сортировка: Древо
1. Йожкин Кот 1051 26.02.16 17:21 Сейчас в теме
Замер времени можно сделать точнее:
ТекущаяУниверсальнаяДатаВМиллисекундах(). Функция появилась в каком-то релизе 8.3
Yakud3a; ZOMI; awk; Dmitriy_T; JesteR; dark_wolf; vladir; +7 Ответить
3. unichkin 1075 02.03.16 12:01 Сейчас в теме
(1) Йожкин Кот, это поддерживается только с 8.2.17
(2) tireal, спасибо за комментарий. Но:
- свою функцию я могу использовать в любом релизе платформы. Да, я порой работаю с 8.1 - как ни странно оно еще есть.
- если мне когда-нибудь понадобится настолько низкоуровневое отслеживание выполнения алгоритма - я скорее воспользуюсь замером времени отладчика
- могу предположить что назначение использования вашей функции - тестирование скорости исполнения алгоритма (т. е. она для этой цели писалась); моей - просто замер времени работы для сообщения/ помещения в лог - секунды вполне устраивают
Останусь при своем, но буду знать и о таком варианте, еще раз спасибо.
6. DrAku1a 1292 03.03.16 02:46 Сейчас в теме
(3) посмотри как сделано в ИР и универсальном отчете (от alexk-is), там есть до миллиекунд.
Попытка
		Scr = Новый COMОбъект("MSScriptControl.ScriptControl");
	Исключение
		Сообщить(ОписаниеОшибки(), СтатусСообщения.Внимание);
		Возврат 0;
	КонецПопытки;
	Scr.Language = "javascript";
	Время = Scr.Eval("new Date().getTime()");
	Возврат Время;
Показать

По поводу разделения строки - держи в копилку:
Функция ИзвлечьСлово(Строка, Разделитель)
	П = найти(Строка+Разделитель, Разделитель);
	Ответ = Лев(Строка, П-1);
	Строка = Сред(Строка, П+СтрДлина(Разделитель));
	Возврат Ответ;
КонецФункции

Пример:
стр = "1,2,3,4";
Сообщить(ИзвлечьСлово(стр, ",")); //1
Сообщить(стр); // 2,3,4
Сообщить(ИзвлечьСлово(стр, ",")); //2
Сообщить(стр); // 3,4
Сообщить(ИзвлечьСлово(стр, ",")); //3
Сообщить(стр); // 4
Сообщить(ИзвлечьСлово(стр, ",")); //4
Сообщить(стр); // "" (пустая строка)
Сообщить(ИзвлечьСлово(стр, ",")); // "" (пустая строка)
Показать

Если заранее известно, что строка не содержит символов перевода строки, то можно пользоваться стандартным:
СтрПолучитьСтроку(СтрЗаменить(<ИсходнаяСтрока>, <Разделитель>, Символы.ПС), <НомерСлова>)
8. unichkin 1075 03.03.16 11:43 Сейчас в теме
(6) Знаю я об этих фишках, спасибо. Функция "ИзвлечьСлово" - не учитывает что символа может и не быть. И режет исходную строку. Как-раз чтобы этого избежать я наваял сп_РазбитьСтроку() - ее конечно не стоит применять на большом массиве данных, но для чтения небольших листов Excell - самое оно.
(7) h00k, почитайте внимательнее мой комментарий в (3) . И да, мне удобнее воспользоваться замером времени, чем вставлять в конфу отладочную печать. Не могу вспомнить случая, когда я не мог без этого обойтись. Может опыта еще маловато)

Имхо, все извращения с получением настолько точного времени - связаны с необходимостью отслеживать СКОРОСТЬ, а не ВРЕМЯ выполнения алгоритма. Разница трудноуловима, но она есть. Мне не надо с точностью до миллисекунды знать сколько времени проводился массив документов - 20 мин меня вполне устроит. Но если я тестирую напр. как быстрее создавать таблицу значений - тут нужны миллисекунды. Просто для универсальности функция замера обычно реализуется наиболее детализированно - т.е. через тот-же ява-скрипт. Ну а мне как-то не нужно было. Если понадобится - возьму из (6).
7. h00k 36 03.03.16 05:28 Сейчас в теме
(3)
- если мне когда-нибудь понадобится настолько низкоуровневое отслеживание выполнения алгоритма - я скорее воспользуюсь замером времени отладчика

Смешно. Вы думаете всякие извращения с джаваскриптами и т.п. появились потому что ни кто не додумался время выполнения в отладчике смотреть?!
Спасибо любимой 1С, они хоть от необходимости использовать внешние скрипты избавили, добавив в платформу функцию
ТекущаяУниверсальнаяДатаВМиллисекундах()

А для старых версий платформы остается только замерять время выполнения при помощи внешних средств, например джава-скрипта.
2. tireal 73 02.03.16 08:36 Сейчас в теме
вот держи в копилку, вместо своего замера
докВремяНачала = ТекущаяУниверсальнаяДатаВМиллисекундах();
//процедура замера
докВремяКонцаВыполнения = ТекущаяУниверсальнаяДатаВМиллисекундах();
докДельта = (докВремяКонцаВыполнения - докВремяНачала) / 1000;


докДельтаПредставление = ПолучитьПредставлениеВремени(докДельта);

Функция ПолучитьПредставлениеВремени(Время)
	Секунды = Время % 60;
	Минуты = (Время-Секунды)/60;
	Минуты = Минуты % 60;
	Часы = (Время-Секунды-Минуты)/3600;
	
	Возврат "" + Окр(Часы) + " ч. " + Окр(Минуты) + " мин. " + Окр(Секунды, 2) + " сек.";
	
КонецФункции
Показать
4. androgin 02.03.16 14:58 Сейчас в теме
вместо Функция РазбитьСтроку(стр, сим)
можно вполне использовать СтрРазделить()
5. unichkin 1075 02.03.16 15:12 Сейчас в теме
(4) androgin, Во-первых назначение СтрРазделить() и моей РазбитьСтроку() - разное. От слова совсем. Во-вторых СтрРазделить() - это начиная с 8.3.6.1977.
12. androgin 13.03.16 02:26 Сейчас в теме
(5) уже давно все типовые версии требуют 8.3.6.2094 как минимальную
14. unichkin 1075 13.03.16 13:18 Сейчас в теме
(12) androgin, далеко не все используют исключительно типовые, и далеко не все еще перешли на новые конфы с УФ и БСП. Я уже писал в (3) что и с 8.1 иногда работаю.
15. androgin 21.03.16 14:33 Сейчас в теме
(14) то, что вы тормозите собственное развитие и сидите в старых платформах и на старых методах - вынуждает вас писать подобные коды и изобретать очередной велосипед.
В 1С далеко не дураки сидят
[email protected]; dj_serega; BigB; the1; smaximaa; +5 5 Ответить
16. h00k 36 21.03.16 22:31 Сейчас в теме
(15) androgin,
то, что вы тормозите собственное развитие и сидите в старых платформах и на старых методах - вынуждает вас писать подобные коды

Вы можете ошибаться... собственное развитие и вынужденная работа со старыми версиями конфигураций в учетных системах заказчика/ работодателя - в большинстве случаев ни как не связаны.
Переход предприятия на новую систему учета/ платформу - это достаточно дорогое удовольствие, и только из-за желания программиста работать с новыми версиями платформ/ конфигураций ни кто, в здравом уме, переходить не будет.
izidakg; mysm; kambl; Dach; eugeniezheludkov; +5 Ответить
17. unichkin 1075 22.03.16 01:56 Сейчас в теме
(15) androgin, не понимаю сути претензий. И с чего вы решили что я где-то там "торможусь"?.. Я подписан на рассылку, просматриваю ИТС, мониторю зазеркалье (о птичках) работаю в основном на 8.3.6. И абсолютно солидарен с вами что в 1С сидят не дураки. Я только не понимаю, к чему это было сказано) Лучше перечитайте (5), попробуйте вникнуть в назначение сп_РазбитьСтроку() и понять таки что СтрРазделитьСтроку() в ее контексте в принципе не нужна. Я наверное сам дал еды троллю - лишним было писать "Во-вторых СтрРазделить() - это начиная с 8.3.6.1977".
9. mars207 27 09.03.16 09:37 Сейчас в теме
Загрузка файлов: выбор на клиенте, обработка на сервере

На веб клиенте давно не работает. Проблема всплывающих окон в браузерах. На последних релизах платформы не тестировал, но подозреваю что не исправили.
10. unichkin 1075 09.03.16 09:39 Сейчас в теме
(9) mars207, тестировал на 8.3.5 - у меня работает. чяднт?
11. androgin 13.03.16 02:25 Сейчас в теме
(9) mars207, все прекрасно работает
13. MishaD 12 13.03.16 10:03 Сейчас в теме
Странно, у меня половина типовых на 8.2.14.540, а еще половина на 7.7.027
18. K_A_O 513 28.03.16 11:33 Сейчас в теме
> Преобразование табличного документа в таблицу значений

Вот это вроде с давних времен работает

Построитель = Новый ПостроительОтчета;
Построитель.ИсточникДанных=Новый ОписаниеИсточникаДанных(ТабДок.Область());       
Построитель.Выполнить();
ТЗ = Построитель.Результат.Выгрузить();
mysm; ZOMI; igormiro; LordKim; BigB; Azimut-tm; terrorion; yukon; pavlov_dv; TreeDogNight; Rokstedi; unichkin; +12 Ответить
21. Altair777 639 06.07.17 09:21 Сейчас в теме
(18) А у меня еще дополнено
Построитель.ДобавлениеПредставлений = ТипДобавленияПредставлений.НеДобавлять;
Построитель.ЗаполнитьНастройки();
19. sansys 47 07.01.17 12:17 Сейчас в теме
Спасибо за статью. Иногда стоит вылезти из своего болота и посмотреть как люди делают :))))) +1
20. ImHunter 21 09.01.17 07:52 Сейчас в теме
Про замеры времени. Написал пару процедур - засечь время и показать время замера (+ 2 вспомогательные). Недостаток - в многопотоке некорректно работает. А так, удобненько.
// клиентский модуль

Процедура ЗасечьТаймер() Экспорт 
	УправляемыйИнтерфейсСервер.СохранитьЗначениеВХранилище( "ТекВремяТаймера", ТекущаяДата() );
	//ПоместитьВоВременноеХранилище( ТекущаяДата(), );
КонецПроцедуры

Процедура ПоказатьВремяТаймера( пЗаголовок = "", пЧерезСообщение = Ложь ) Экспорт 
	д = УправляемыйИнтерфейсСервер.ПолучитьЗначениеИзХранилища( "ТекВремяТаймера" );
	общ = ТекущаяДата() - д;
	мин = цел( общ / 60 );
	сек = общ - мин * 60;
	час = цел( мин / 60);
	мин = мин - час * 60;
	лВрем = ?( пЧерезСообщение, "Время выполнения:", "Время:" );
	Если час <> 0 Тогда 
		лВрем = лВрем + " " + час + " час"
	КонецЕсли;
	Если Мин <> 0 Тогда 
		лВрем = лВрем + " " + мин + " мин"
	КонецЕсли;
	лВрем = лВрем + " " + сек + " сек";
	Если пЧерезСообщение=Ложь Тогда 
		ПоказатьОповещениеПользователя( пЗаголовок, , лВрем );
	Иначе 
		Сообщить( ?( ПустаяСтрока( пЗаголовок ), "Действие выполнено", пЗаголовок ) + ". " + лВрем );
	КонецЕсли;
КонецПроцедуры

// серверный модуль УправляемыйИнтерфейсСервер

Процедура СохранитьЗначениеВХранилище( пКлюч, пЗначение ) Экспорт
	ХранилищеСистемныхНастроек.Сохранить( , пКлюч, пЗначение, , ПараметрыСеанса.ТекущийПользователь );	
КонецПроцедуры

Функция ПолучитьЗначениеИзХранилища( пКлюч ) Экспорт
	Возврат ХранилищеСистемныхНастроек.Загрузить( , пКлюч, , ПараметрыСеанса.ТекущийПользователь );
КонецФункции


// пример использования
&НаКлиенте
Процедура СделатьЧтоТо()
  УправляемыйИнтерфейс.ЗасечьТаймер();
  // что-то делаем
  // ......................
  УправляемыйИнтерфейс.ПоказатьВремяТаймера("Сделали что-то!");
КонецПроцедуры

Показать
22. nSpirit2 09.08.17 13:55 Сейчас в теме
Я конечно все понимаю но раз вы пишите
Код я оформляю в соответствии с соглашениями о написании кода.


Еще раз прочитайте эту часть
https://its.1c.ru/db/v8std#content:2149184103:hdoc

Мне кажется вы не правильно поняли блок как не надо делать
23. unichkin 1075 09.08.17 17:34 Сейчас в теме
(22)
Мне кажется вы не правильно поняли блок как не надо делать

Какой участок кода навел вас на эту мысль?
24. LexSeIch 195 31.10.17 03:49 Сейчас в теме
Мир этому дому! Всегда приятно ознакомиться с чьим то опытом, и не менее приятна дискуссия по его обсуждению, где рождается если не истина, то разные варианты решения. Порой фраза в таком обсуждении рождает новые идеи даже не связанные, с текущей темой.
25. Aphanas 126 31.07.18 13:42 Сейчас в теме
Функция ИдентификаторПоСтроке соответствует алгоритму платформы?
26. unichkin 1075 31.07.18 19:53 Сейчас в теме
(25)
Функция ИдентификаторПоСтроке соответствует алгоритму платформы?

Специально не тестил, свое предназначение выполняет; вообще, должна. Возможно в регистрах символов будет различие, но т.к не имею кода платформы на руках 100% гарантии дать не могу)
27. SerVer1C 153 12.11.18 13:29 Сейчас в теме
Функция ЭтоGUID(Идентификатор)
	Попытка
		GUID = Новый УникальныйИдентификатор(Идентификатор);
	Исключение
	КонецПопытки;
	
	Возврат GUID <> Неопределено;
КонецФункции
28. unichkin 1075 12.11.18 20:59 Сейчас в теме
(27) Решать задачи через попытку там где можно ее не использовать - очень плохой тон.
29. SerVer1C 153 13.11.18 08:18 Сейчас в теме
(28) Эту фразу вы вычитали в "умных" книжках? Корректная работа с СУБД при записи данных идет через попытку. Вы считаете, что использовать портянки кода там, где можно обойтись одной строкой, это хороший тон? Сначала доработайте алгоритм, чтобы он не считал "zzzzzzzz-zzzz-zzzz-zzzz-zzzzzzzzzzzz" валидным ГУИДом, а потом еще проверьте его на быстродействие.
30. Артано 633 13.11.18 10:05 Сейчас в теме
(29) Регулярные выражения. По быстродействию предлагаю провести сравнение. Было бы инетересно
31. SerVer1C 153 13.11.18 13:05 Сейчас в теме
(30) Замерил с помощью внешней компоненты /public/940766 на венде х64 - получился прирост в скорости в ~16 раз. Использовал шаблон "([0-9A-Fa-f]{8})-([0-9A-Fa-f]{4})-([0-9A-Fa-f]{4})-([0-9A-Fa-f]{4})-([0-9A-Fa-f]{4,12})"
32. Артано 633 13.11.18 14:31 Сейчас в теме
(31) А в цифрах для каждого типа?
33. unichkin 1075 13.11.18 14:53 Сейчас в теме
(29) я эту фразу пережил на собственном опыте. Попробуйте поотлаживаться когда есть пара сотен итераций цикла, и на каждой происходит выброс по попытке.
34. SerVer1C 153 13.11.18 15:01 Сейчас в теме
(33) Для этого давным-давно придумали замечательную вещь: Исключения.
35. unichkin 1075 13.11.18 17:37 Сейчас в теме
(34) не понимаю, о чем вы, если можно - подробнее? з.ы. я не уточнил - имелась в виду отладка с включенным флагом "Остановка по ошибке".
36. svilsa 1 14.11.18 11:55 Сейчас в теме
Очень классно, спасибо!!! Такая шпаргалка в закладках, чтобы не ломать каждый раз голову. Коротко и ясно.
Оставьте свое сообщение